Vuex requires a Promise polyfill in this browser

在使用Vuex时,使用ie浏览器会出现“Vuex requires a Promise polyfill in this browser”的错误提示,这是因为使用了ES6 Promise,而IE浏览器不支持,解决方案如下:

1.安装babel-polyfill

1
npm install --save babel-polyfill

2.引入babel-polyfill

在webpack.config.js中增加(如果使用的是vue-cli+vue webpack模板则在webpack.base.conf.js中增加):

1
2
require("babel-polyfill"); //es5
//import "babel-polyfill"; //es6

3.使用babel-polyfill

将webpack.config.js(如果使用的是vue-cli+vue webpack模板则是webpack.base.conf.js)文件中的

1
2
3
4
5
module.exports = {
entry: {
app: './src/main.js'
}
……

修改为

1
2
3
4
5
module.exports = {
entry: {
app: ['babel-polyfill', './src/main.js']
}
……

完成

坚持原创技术分享,您的支持将鼓励我继续创作!